You are currently not logged in.  Logon or register to access more features. Vision-Riders.com is a FREE service provided by Victory Riders Network.

Search:




Dead miss on acceleration
Jump to page : 1
Now viewing page 1 [25 messages per page]
View previous thread :: View next thread
   Discussion -> Vision Tech Q&AMessage format
 
Colorado Kid
Posted 2020-05-23 5:58 PM (#193017)
Subject: Dead miss on acceleration


Puddle Jumper

Posts: 9
Ok, put a set of thrush on my 09 Vision, left Cats in, installed Loydz fuel tuner, set on stage one exhaust, no intake changes, disconnected o2's.. It now has a dead miss on acceleration, stumbles, backfires.. No exhaust leaks, can't find any intake leaks, have new plug wires on order as they look stock with 66K on em, ordered new vacuum lines.. Plugs look a little weird, tips light, black electrodes.. Any ideas, am I on the right track?



Edited by Colorado Kid 2020-05-23 5:58 PM
Top of the page Bottom of the page
rdbudd
Posted 2020-05-24 1:01 PM (#193018 - in reply to #193017)
Subject: RE: Dead miss on acceleration


Visionary

Posts: 1622
Jasper, MO
Have you tried new plugs? Also, black electrodes could indicate too much fuel to me. You could unhook the ground wire to the tuner, which will temporarily disable it, and see if the problem goes away. I would try new plugs first.

Ronnie
Top of the page Bottom of the page
Colorado Kid
Posted 2020-05-24 10:36 PM (#193019 - in reply to #193018)
Subject: RE: Dead miss on acceleration


Puddle Jumper

Posts: 9
Thanks, going to get new plugs Tuesday, ordered a Loydz IAR also.. Maybe I can get this thing going right..
Top of the page Bottom of the page
Colorado Kid
Posted 2020-05-25 5:26 PM (#193020 - in reply to #193017)
Subject: Re: Dead miss on acceleration


Puddle Jumper

Posts: 9
Update, put some new plugs in, seems to be a little better..
Top of the page Bottom of the page
Colorado Kid
Posted 2020-06-24 4:01 PM (#193038 - in reply to #193017)
Subject: Re: Dead miss on acceleration


Puddle Jumper

Posts: 9
Update, after new plugs, new wires, Loydzz top filter, IAR, and some seat of the pants tuning, this sucker runs GREAT! Took a shake down cruise yesterday..
Top of the page Bottom of the page
lennyb
Posted 2020-06-25 3:48 PM (#193039 - in reply to #193017)
Subject: Re: Dead miss on acceleration


Iron Butt

Posts: 789
Bel Air, MD
Good job, ENJOY!!

Excellent reminder to myself - ordered a new set of plugs and fuel system cleaner today.
Top of the page Bottom of the page
rdbudd
Posted 2020-06-26 1:29 AM (#193040 - in reply to #193038)
Subject: Re: Dead miss on acceleration


Visionary

Posts: 1622
Jasper, MO
Good job!! It sounds like you might have had the tuner set too rich and fouled the plugs initially. Now that you have added the top filter, you can use the extra fuel which, with the added air flow and added fuel, has likely gained you a bit more power.

Ronnie
Top of the page Bottom of the page
Jump to page : 1
Now viewing page 1 [25 messages per page]
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

Copyright © 2007-2020 Victory Riders Network™